~ Forums of Enroth ~

An Enroth diehard fan community
 
HomeHome  ChatChat  FAQFAQ  SearchSearch  RegisterRegister  Log inLog in  
Latest topics
» H3SW Recruitment Point - Enroth Needs You!
by MaXenaeL 2018-07-14, 02:00

» Хочу сделать коллаж по любимой игре
by Stryker34RUS 2018-07-11, 03:19

» Advanced Dialogue Boxes in Project Ironfist
by DarkAtom 2018-07-03, 04:32

» H3SW: General Graphics discussion
by Orzie 2018-06-25, 03:32

» I'm looking for one really crazy map to H2
by Orzie 2018-06-25, 03:23

» MasterMind Heroes: The Succession Wars (wip title)
by Orzie 2018-06-25, 03:20

» Introduce yourself
by Orzie 2018-06-25, 02:48

Poll
"Wait" in HoMM2?
Yes
80%
 80% [ 55 ]
No
20%
 20% [ 14 ]
Total Votes : 69
Most Viewed Topics
H3SW: General Graphics discussion
Ragoon's Graphics For HoMM3SW
H3SW General Discussion
H3SW: Dwelling Development
H3SW Map List: Work in progress
Enrothian Fan Art
Commanders?
Dervish Faction General Concept
Welcome fellow Enrothians!
H3SW Recruitment Point - Enroth Needs You!

Share | 
 

 [Modding Tools] Error with FRM program

Go down 
AuthorMessage
DarkAtom
Skeleton
Skeleton
avatar

Messages : 8
Quality Points : 1
Registration Date : 2018-02-27

PostSubject: [Modding Tools] Error with FRM program   2018-03-03, 09:48

When I edit the game files, everything works fine until I want to edit creature frame information. Let's take LICH_FRM.BIN for example. I copy that to the same folder where H2FRMUnpack.exe is located. I drag the .BIN file onto the .exe and then:

Quote :
H2FRMUnpack.exe - System Error

The code execution cannot proceed because MSVCR100D.dll was not found. Reinstalling the program may fix this problem

If I am not mistaken, that is a Visual Studio C++ component, but it ends with a 'D' which is weird. Even though I have Visual Studio Community 2017 and both 32 bit and 64 bit versions of the MS Visual C++ 2005, 2008, 2010, 2013 and 2017 redistributables, searching my whole hard drive could not find the file. I do have MSVCR100.dll, though, notice how it doesn't end with a 'D'.

I tried the packer with the example .BIN.ini files it comes with and the unpacker with both original H2 files and Ironfist files, with no success. Even running it as an administrator or running it under compatibility didn't work.

I tried to reinstall it but it didn't work either. This is the link I have been using to download the tools: projectironfist.pbworks.com/w/file/68304143/IronfistTools.zip
Back to top Go down
Darmani
Master Modder
Master Modder
avatar

Messages : 184
Quality Points : 36
Registration Date : 2014-12-27

PostSubject: Re: [Modding Tools] Error with FRM program   2018-03-31, 16:39

Hi DarkAtom,

That "D" refers to the debug version of that DLL. I've asked one of our programmers to rebuild it in release mode. In the meantime, you can Google for that file.
Back to top Go down
Darmani
Master Modder
Master Modder
avatar

Messages : 184
Quality Points : 36
Registration Date : 2014-12-27

PostSubject: Re: [Modding Tools] Error with FRM program   2018-04-03, 03:40

Newly-built FRM tools are available from https://github.com/jkoppel/project-ironfist/tree/master/tools/frm .
Back to top Go down
DarkAtom
Skeleton
Skeleton
avatar

Messages : 8
Quality Points : 1
Registration Date : 2018-02-27

PostSubject: Re: [Modding Tools] Error with FRM program   2018-04-08, 04:43

Darmani wrote:
Newly-built FRM tools are available from https://github.com/jkoppel/project-ironfist/tree/master/tools/frm .
Thank you, it's working like a charm!
Back to top Go down
Sponsored content




PostSubject: Re: [Modding Tools] Error with FRM program   

Back to top Go down
 
[Modding Tools] Error with FRM program
Back to top 
Page 1 of 1
 Similar topics
-
» Error message at program startup
» OSISS program would have prevented suicide of a young RCMP officer with PTSD
» browser error occured [Error #230]
» Error Code #230 - it's BACK!!
» Error Code 64: Host not available!

Permissions in this forum:You cannot reply to topics in this forum
~ Forums of Enroth ~ :: Modding Guild :: Heroes of Might and Magic II: Project Ironfist-
Jump to: